Events &

Studio & FAQ

Contact us

About us

Recommendations for Flash player to see our panoramas:

PC / Internet Explorer

The Adobe® Flash Player plug-in should be installed (most of the time it is already). If not, please download the Flash player plug-in here:
get Flash player for Internet Explorer

MAC / Safari

Mac / Safari was not supporting Flash until lately. However, if you are running MAC OS X 10.4 and better than you can download and install the newest Flash plug-in here:
Flash for MAC OS 10.4 and later

Flash player for MAC OS 10.1, Linux, Solaris, Win98/ME, etc.

Download the right Flash player version here:
Flash for other systems

Always check carefully the system requirements on the download pages to find out whether your system matches the Flash version you are going to download.